Rawhide Watch

Daily warnings for rawhide victims

Archive for December, 2013

GNOME fail (again) thanks to libevdev 0.6-1

Posted by adamwill on December 27, 2013

A couple of days ago, a new libevdev build, 0.6-1, was sent to Rawhide. It changed the ABI of libevdev.so.1 by dropping some ‘deprecated’ functions, without bumping the library version (soname). Unfortunately, clutter was still using these ‘deprecated’ functions: upstream clutter git had been updated to use the replacement functions, but no release had yet been cut with this change, and it had not been backported to Fedora.

This meant that if you installed libevdev-0.6-1.fc21, GNOME would fail to start up, with gnome-shell reporting a failure in clutter:

gnome-shell: symbol lookup error: /lib64/libclutter-1.0.so.0: undefined symbol: LIBEVDEV_READ_NORMAL

We’ve now sent out a libevdev-0.6-2.fc21 build which restores the dropped functions, and also a clutter-1.16.2-4.fc21 build which backports the fix to use the replacement functions, thus fixing the bug from both ends for extra safety. If you’re currently suffering from this bug, updating libevdev, clutter or both should resolve it.

Posted in Topical but Not Interesting Later | 1 Comment »

SELinux execmem and execstack denials for everything, and GNOME not running

Posted by adamwill on December 23, 2013

So hey, this blog still exists!

For this author (AdamW), there are two major issues in Rawhide currently. SELinux appears to be denying ‘execmem’ and ‘execstack’ access to all sorts of stuff – this is affecting dhclient (stopping networking working), sshd, sssd (for those of us who use FreeIPA authentication), cups and several other things. I haven’t looked into what caused this exactly yet, but booting with enforcing=0 is likely to be a requirement for Rawhide users until it gets figured out. Bugs filed so far are #1046112 and #1045682.

Also for this author, GNOME currently fails to run at all. GDM doesn’t start, and if I boot to runlevel 3 and run startx I get an extremely broken GNOME session with Shell not running and windows all over the shop. For now, I’ve switched to Xfce. I suspect this is because about half of GNOME 3.11.3 got built before most of the desktop team left for the holidays, but again don’t have precise details yet. We may be able to get it fixed up with the help of any desktop folks who are still around.

Update on GNOME: turns out it just needs a new gsettings-desktop-schemas build. That is now in progress – grab that when it’s done, and GNOME should work again, with all other components at their latest Rawhide level.

Posted in Topical but Not Interesting Later, Uncategorized | 4 Comments »