Rawhide Watch

Daily warnings for rawhide victims

Unable to update to rawhide – rpmlib(PayloadIsXz)

Posted by rawhidewatch on July 31, 2009

jlaska wrote:
Trying to update your Fedora 11 (or older) system to the latest rawhide content?  You might notice a failure similar to below when attempting to upgrade using yum:

rpmlib(PayloadIsXz) <= 5.2-1 is needed by kernel-PAE-2.6.31-0.107.rc4.git3.fc12.i686 
rpmlib(PayloadIsXz) <= 5.2-1 is needed by kernel-firmware-2.6.31-0.107.rc4.git3.fc12.noarch

Turns out that rawhide packages now use XZ (the new LZMA format) as the default payload compression format.  The details of this new feature can be found on the XZRpmPayloads feature page.  Testers that install directly from Fedora 12 or rawhide should not experience problems.  However, folks upgrading from Fedora 11 or from an older rawhide may need to manually workaround this issue using the following commands:

yum --enablerepo=updates-testing update rpm

Once completed, you may continue with the rawhide upgrade:

yum --disablerepo=* --enablerepo=rawhide update

More information on upgrading to rawhide can be found on the wiki.

Happy testing!

About these ads

Sorry, the comment form is closed at this time.

 
Follow

Get every new post delivered to your Inbox.

%d bloggers like this: